Jump to content
vinimino

Mouse cursor position and click doesn't match

Recommended Posts

Windows 7 x64, and I'm using 1080 GTX with 390.77 driver.

My desktop res. is 4k with with 200% DPI for text scaling. PUBG resolution is 2560 x 1440.

 

I've been playing PUBG, deleted it and reinstalled it today. I hadn't had this problem before, but now with the full screen mode I can't click more than 1/4 of my screen in upper left area. Actual clicks happen in exactly half of the mouse cursor position, starting from upper left end. It's like clickable area is trapped in 1920 x 1080 in upper left. I can move the cursor around from end to end, but this problem happens both in the lobby screen and in-game.

 

It seems that the game recognizes Windows' 200% DPI setting for text scaling, even with "Disable display scaling on high DPI settings" option checked.

 

Windowed mode works fine but I want the full screen mode for better performance and without Windows' taskbar.

 

Yes, I changed settings in GameUserSettings.ini but it doesn't work. Even deleted all ini files, doesn't work either.

 

Yes, I did check/uncheck high DPI aware option for tslgame.exe and also changed HIGHDPIAWARE option in registry, but no luck.

 

In registry editor, I found out something strange. In HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers, if I run PUBG a couple of times, data entry looks like HIGHDPIAWARE HIGHDPIAWARE HIGHDPIAWARE HIGHDPIAWARE HIGHDPIAWARE HIGHDPIAWARE... It's not a single option but multiple, but the same option. Is this a BUG??

 

Other games work just ok.

 

BLUEHOLE, PLEASE FIX IT.

Share this post


Link to post
Share on other sites

Finally fixed it, with the only data entry HIGHDPIAWARE in

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

for tslgame.exe in the registry. Yay!

Edited by vinimino

Share this post


Link to post
Share on other sites

Well, actually it's only half fixed.

 

I checked "Windows xp style dpi scaling" in Windows desktop settings - this way I can make PUBG mouse cursor clicks work properly.

 

But with the option above unchecked, clickable area is limited - 1/4 of my screen in upper left area.

 

So the problem is still there with Windows xp style dpi scaling on (not for PUBG anyway) and other desktop apps look weird now... :( 

Share this post


Link to post
Share on other sites

Workaround: Change text scaling to 100% (sucks, cause everything is too small to read).

 

2nd option: Try to change your text scaling to the one you used before by the "custom scaling" option. 

Worked for me so far but don't know yet if it will still work after a restart. 

Share this post


Link to post
Share on other sites

I read another post somewhere saying this is fixed, and now I can confirm it. The problem is gone now.

 

I've been struggling to solve this issue but it was really a PUBG bug...

 

 

Share this post


Link to post
Share on other sites
5 hours ago, MalakaGuy said:

It may appear again. They just rolled back the update because of people having other issues.

 

OMG really? Didn't know much about the rollback. :(

Share this post


Link to post
Share on other sites

i run 4k and windows scale and layout 200% and may have found a solution.

 

first go to the game files and right click on tslgame and go the compatibility then click on high dpi settings and tick the box under program dpi this worked for me

image.png.826d3cc519332eb3394d36ac4b6ad8d2.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...