Jump to content

Search the Community

Showing results for tags 'game slow down'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • PLAYERUNKNOWN'S BATTLEGROUNDS
    • Forum Rules & Guidelines
    • Report A Player & Appeals
  • Game Announcements & Forum Info
  • Gameplay Discussion & Suggestions
  • PC
    • PC News & Patch Notes
    • Game Discussion & Feedback
    • Help & Troubleshooting
    • Bug Reports & Known Issues
    • Test Server
  • Xbox
    • Xbox News & Patch Notes
    • Game Discussion & Feedback
    • Help & Troubleshooting
    • Bug Reports & Known Issues
    • Test Server
  • PS4
    • PS4 News & Patch Notes
    • Game Discussion & Feedback
    • Help & Troubleshooting
    • Bug Reports & Known Issues
    • Test Server
  • PUBG API Community Developers
    • Getting Started
    • Announcements
    • Community Developer General Discussion
    • Community Developer Projects
    • Community Developer Help
  • Community
    • Introductions
    • Looking For Players
    • Community Content
    • Off Topic
  • Other Languages
    • Russian
    • Turkish
    • German
    • French
    • Spanish
    • Portuguese
    • Polish
    • Italian

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 1 result

  1. Hello! I want to mention this first: I am stupid and I don't know where this kind of issue should be reported. I don't know what happened yesterday, but Jesus Christ and almighty Buddha, I was having Lag EVEN in the Lobby/Game Menu!! Even my mouse cursor was lagging in the Lobby... I restarted the game a couple of times, then the PC, nothing changed. I changed the Graphic settings to ''Fullscreen Windowed'' and it was worse, then changed it back. Two days ago I was getting the ''bad module error'' and ''game crash + error report'', now the servers and client slowed down 80%... Of course, I reported those too. By the way, I'm playing on the EU region, since I'm from EU, if this matters or not. My rig is brand new and very capable. Everything runs perfectly, so it can't be my PC. Drivers and updates are up to date too. Did anyone had or still has this issue? Thank you!
×
×
  • Create New...